Nexus Repository 3.41.0 - 3.41.1 Release Notes

Nexus Repository 3.41.0 - 3.41.1 Release Notes

#### Highlights in This Release
Warning
Critical Nexus Repository Pro Cleanup Policy Bug Fix (3.41.1)
This release fixes a critical cleanup policy bug impacting some Nexus Repository Pro deployments. See the official advisory for full details on who is impacted and how to remediate this issue.
New Optional Database Migrator Parameters (3.41.0)
We have added two new optional parameters that you can use to preserve and reuse the JSON files that Database Migrator exports during the migration process.
New Admin - delete blobstore temporary files Task (3.41.0)
In this release, we added a new task that you can manually schedule to reduce excess tmp files if this is a problem for your organization.

3.41.1 Release August 19, 2022

Critical Nexus Repository Pro Cleanup Policy Bug Fix

This release fixes a critical bug (NEXUS-34642) that could cause cleanup policies to unintentionally delete binaries in Nexus Repository Pro deployments using H2 or PostgreSQL.

Deployments meeting all of the following criteria are impacted by this bug:

Critical Nexus Repository Pro Cleanup Policy Bug Fix

See the official advisory for full details on who is impacted and how to remediate this issue.

3.41.0 Release July 27, 2022

New Optional Database Migrator Parameters

The Database Migrator exports the OrientDB database to JSON files during the migration process and then deletes these files. In this release, we've added two optional parameters that you can use if you'd like to preserve the JSON files to potentially reuse them without any additional export. This can be especially helpful should you encounter any issues causing the import to the target database to finish unexpectedly. We also added a flag to allow you to "assume yes" and skip waiting for manual user input when prompted to ensure that Nexus Repository is shut down before proceeding.

New Admin - delete blobstore temporary files Task

As some customers have reported experiencing excess tmp files in a blobstore's /tmp folder, we have added a new Admin - delete blobstore temporary files task to help reduce excess files. If you find that you have excess tmp files for a blobstore, manually schedule and use this task to easily delete all of the tmp files (.bytes and .properties) in a selected blobstore's /tmp folder.

Upgraded Embedded Java Version for Windows and MacOS

In this release, we upgraded our embedded JDK version from Java 8u252 to 8u332 to improve overall security and stability. This only affects Windows and MacOS installers.

Hosted PyPI Repositories Now Use SHA256 Hashes

As recommended in PEP 503, hosted PyPI repositories now provide SHA256 hashes instead of MD5 in the /simple web interface's href attributes that link to package files being served.

Note that this behavior cannot be reverted once you upgrade to 3.41.0.

Bug Fixes Description
NEXUS-27383 Adding Helm charts no longer results in excess tmp files (.bytes and .properties) in the /tmp folder.
NEXUS-31314 The Docker hosted REST API now treats deployment policy the same as it is treated in the UI.
NEXUS-31512 Fixed an issue that was causing invalid blob references and a 500 response for subsequent GET requests after deploying maven-metadata.xml.
NEXUS-31761 The Database Migrator will exit if it detects that another process has the database open.
NEXUS-31970 The npm group dist-tags endpoint now merges duplicate npm tagged versions using the first group member resolved version.
NEXUS-32580 The Database Migrator no longer attempts to drop existing SQL database tables by default.
NEXUS-32613 Fixed an issue that was causing errors with hosted PyPi repository indexes.
NEXUS-32634 Fixed an issue that was causing errors when importing some Docker images.
NEXUS-32658 Using the REST API to create the same repository twice no longer creates errors that prevent the repository list from loading or cause subsequent API attempts to delete the repository to fail.
NEXUS-33290 The Database Migrator no longer fails when assets contain an unexpected date/time.
NEXUS-33541 Running the Repair - Reconcile component database from blob store task with Integrity Check immediately after migrating to a PostgreSQL database will not remove any test files you previously uploaded to the database.
NEXUS-33584 When using subdomain routing, the request.log log line now shows the actual path to the repository as part of the path that is logged.
NEXUS-33613 Fixed an error that was occurring with the Nexus System API UI when using context path.
NEXUS-33733 Fixed an error that was blocking the ability to create an externally mapped role for SAML via the UI.
NEXUS-33949 A GAV metadata rebuild (lazy or via rebuild task) will no longer impact the GA metadata file.
NEXUS-34020 Deleting a tag only results in a disassociation attempt against the associated components.