Using Nexus as docker registry - Sonatype Nexus Repository / Best Practices - Sonatype Community
Using Nexus as docker registry
post by deepforu47 on Jul 1, 2021
Kuldeep Sharma
My Setup
Ingress Routes (example dns names and resolving using host file)
- Web Interface ( nexus.bar.com) → Nexus Service (Working)
- Docker Registry ( docker.bar.com) → Nexus Service (Not Working)
Created self signed certificate for both dns.
Repository Browsing working
Trying to login to nexus docker registry
⚙️ $ docker login demo.azure.com
Username: admin
Password:
INFO[0005] Error logging in to endpoint, trying next endpoint error="Get\"https://demo.azure.com/v2/\": x509: certificate signed by unknown authority"
Get "https://demo.azure.com/v2/": x509: certificate signed by unknown authority
I know this is more on ingress controller certificate management, but just want to check if someone has configured this using non existing domain and with self signed certificate?
Second thing what are the best practices when we take this to production while using:
- K8S platform for deployment
- Ingress for accessing
- Do we need to existing domain name at least for docker stuff, so that registry name should get resolved from different components through full CI/CD life cycle?
Any help will be appreciated.
post by rseddon on Jul 1, 2021
Rich Seddon
Docker is pretty picky about certificates, have a look here: