Nexus startup failed, version Nexus 3.70.3-01 - Sonatype Nexus Repository - Sonatype Community

Nexus startup failed, version Nexus 3.70.3-01

Post by aa67345 on Oct 26, 2024

Nexus failed to start, I found 2 error messages as follows: ERROR1, ERROR2.

ERROR1:

2024-10-27 06:51:51,468+0800 WARN [FelixStartLevel] *SYSTEM Sisu - Problem adding: org.eclipse.sisu.inject.LazyBeanEntry@250bfa46 to: org.sonatype.nexus.datastore.mybatis.MyBatisDataStore$$EnhancerByGuice$$14da4b92@205a2b1 via: org.sonatype.nexus.datastore.internal.DataStoreManagerImpl$DataAccessMediator@f3c60f8

org.sonatype.nexus.datastore.api.DataAccessException:

Error updating database. Cause: org.h2.jdbc.JdbcSQLNonTransientException: General error: “org.h2.mvstore.MVStoreException: Chunk 13011 not found [2.2.224/9]”; SQL statement:

CREATE TABLE IF NOT EXISTS maven2_asset_blob (
    asset_blob_id INT GENERATED BY DEFAULT AS IDENTITY,
    blob_ref VARCHAR NOT NULL,
    blob_size BIGINT NOT NULL,
    content_type VARCHAR NOT NULL,
    checksums JSON NOT NULL,
    blob_created TIMESTAMP WITH TIME ZONE NOT NULL,
    created_by VARCHAR,
    created_by_ip VARCHAR,
    CONSTRAINT pk_maven2_asset_blob_id PRIMARY KEY (asset_blob_id),
    CONSTRAINT uk_maven2_asset_blob_ref UNIQUE (blob_ref)
);

The error may exist in org.sonatype.nexus.content.maven.store.Maven2AssetBlobDAO

The error may involve defaultParameterMap

The error occurred while setting parameters


ERROR2:

Caused by: org.h2.jdbc.JdbcSQLSyntaxErrorException: Table “MAVEN2_BROWSE_NODE” not found; SQL statement:

ALTER TABLE maven2_browse_node ALTER COLUMN node_id SET DATA TYPE BIGINT;

Post by wiget on Oct 28, 2024

I reported this issue in September with a possible workaround: "org.h2.mvstore.MVStoreException: Chunk 44722 not found" on first Nexus start after DB migration (3.70.2)

Post by aa67345 on Nov 1, 2024

Thank you for your help. I have adopted this repair method and the service can start normally, but after starting, all Maven packages in the group are missing.

Latest Logs

nexus.log
2024-11-02 10:05:39,482+0800 WARN [periodic-5-thread-1] *SYSTEM org.apache.ibatis.executor.BaseExecutor - Unexpected exception on closing transaction. Cause: org.h2.jdbc.JdbcSQLNonTransientConnectionException: Database is already closed (to disable automatic closing at VM shutdown, add “;DB_CLOSE_ON_EXIT=FALSE” to the db URL) [90121-232]

Further Errors

2024-11-02 10:05:39,484+0800 WARN [quartz-10-thread-3] *SYSTEM org.apache.ibatis.executor.BaseExecutor - Unexpected exception on closing transaction. Cause: org.h2.jdbc.JdbcSQLNonTransientConnectionException: Database is already closed (to disable automatic closing at VM shutdown, add “;DB_CLOSE_ON_EXIT=FALSE” to the db URL) [90121-232]