LDAP server connection issue - Sonatype Nexus Repository - Sonatype Community
LDAP server connection issue
post by nathay0 on Mar 10, 2021
Hi there,
We are using OSS 3.27.0-03 version of Nexus RM inside docker container.
I’m currently trying to configure LDAP authentication but I’m stuck on the very beginning:
Failed to connect to LDAP Server: XXXXX:389 [Caused by java.net.UnknownHostException: XXXXX]
When I test the connection from the container itself using: ldapsearch and same credentials I use in Nexus - it works fine
Any ideas guys ?
post by mpiggott on Mar 10, 2021
Java Documentation on UnknownHostException
post by nathay0 on Mar 11, 2021
Guess it was DNS issue - adding entry to etc/hosts solved my problem.