# Error when using repository

## post by Andrew_Meyer on Aug 25, 2025

I am trying to pull container images from [registry.redhat.io](http://registry.redhat.io/) and i’m getting this error when using nexus repo manager. I am using podman for this. Here is the error:

```swift
DEBU[0001] Error pulling candidate nexus01.example.com:9093/rhel9/nginx-120:latest: internal error: unable to copy from source docker://nexus01.example.com:9093/rhel9/nginx-120:latest: copying system image from manifest list: parsing image configuration: fetching blob: unauthorized: access to the requested resource is not authorized
Error: internal error: unable to copy from source docker://nexus01.example.com:9093/rhel9/nginx-120:latest: copying system image from manifest list: parsing image configuration: fetching blob: unauthorized: access to the requested resource is not authorized
```

## post by mpiggott on Aug 25, 2025

You have some sort of authentication error. Either between the client and Nexus, or Nexus and the remote registry.

## post by Andrew_Meyer on Aug 25, 2025

I have anonymous access turned on…and this is trying to access redhat container registry.

## post by Andrew_Meyer on Aug 25, 2025

Also if I look at the datastore for the repo, I see the container browsing the web ui.

Is there any special trick to make this work with redhat’s container registry let alone yum/dnf repos?

## post by Andrew_Meyer on Aug 25, 2025

I got this resolved. It was an auth issue on the nexus to repo side.

## post by Andrew_Meyer on Aug 25, 2025

ok, so I tried switching this up and using a service account from redhat, but it looks like i’m having an auth issue again. Can you verify?

```bash
DEBU[0000] Accessing "nexus.example.com:9093/rhel9/cups:latest" failed: reading manifest latest in nexus.example.com:9093/rhel9/cups: manifest unknown
DEBU[0000] Error pulling candidate nexus.example.com:9093/rhel9/cups:latest: internal error: unable to copy from source docker://nexus.example.com:9093/rhel9/cups:latest: initializing source docker://nexus.example.com:9093/rhel9/cups:latest: reading manifest latest in nexus.example.com:9093/rhel9/cups: manifest unknown
Error: internal error: unable to copy from source docker://nexus.example.com:9093/rhel9/cups:latest: initializing source docker://nexus.example.com:9093/rhel9/cups:latest: reading manifest latest in nexus.example.com:9093/rhel9/cups: manifest unknown
```

## post by mpiggott on Aug 25, 2025

There is an outbound request log which you can examine for requests made by nexus to remotes.

## post by Andrew_Meyer on Aug 25, 2025

I didn’t know that. Thanks!
